Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
The Document.
- referenceToFace
- Type: Autodesk.Revit.DB Reference
A Reference to a Face of a MassEnergyAnalyticalModel.
Return Value
Returns References to Faces from MassZones coincident with an input Face from a MassEnergyAnalyticalModel.Remarks
The results are always References to Faces. The Reference Type should report as REFERENCE_TYPE_SURFACE. Currently Revit improperly reports it as REFERENCE_TYPE_NONE.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The Reference is not a Face of a MassEnergyAnalyticalModel. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |