Builds the type shape from the supplied collection of GeometryObjects. The objects are copied. If the new shape is identical to the old one, the old shape will be kept.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.2.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- pGeomArr
- Type: System.Collections.Generic IList GeometryObject
Shape of this object expressed as a collection of GeometryObjects. These will be copied. Shape and Category should be consistent: geometry supplied as shape should be valid for the Category the type object is associated with. The supported types of GeometryObjects are: Solid, Mesh, GeometryInstance, Point and Curve.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | At least one member of pGeomArr does not satisfy DirectShapeType validation criteria. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |