Constructs a new instance of a file to match elements that have a given phase status on the input phase, with the option to match all elements that have a phase status other than the input status.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- phaseId
- Type: Autodesk.Revit.DB ElementId
Id of the phase.
- phaseStatus
- Type: Autodesk.Revit.DB ElementOnPhaseStatus
Target status.
- inverted
- Type: System Boolean
True to match all phase statuses other than the input status.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | A value passed for an enumeration argument is not a member of that enumeration |