Returns a curve that corresponds to this edge as oriented in its topological direction on the specified face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- faceForDir
- Type: Autodesk.Revit.DB Face
Specifies the face, on which the curve will follow the topological direction of the edge.
Return Value
It can be an Arc, Line, or HermiteSpline.Remarks
Evaluating the edge using EvaluateOnFace gives the same result as evaluating the curve returned by AsCurveFollowingFace with a normalized curve parameter. When a Hermite spline is returned, the two evaluated points will be approximately equal.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the specified faceForDir is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions ArgumentException | Thrown when the specified faceForDir is not one of the faces for this edge. |