GetCurrentConstraintOnHandle Method


Retrieves the RebarConstraint that acts on the specified RebarConstraintHandle.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2014

Syntax

C#
public RebarConstraint GetCurrentConstraintOnHandle(
	RebarConstrainedHandle handle
)
Visual Basic
Public Function GetCurrentConstraintOnHandle ( _
	handle As RebarConstrainedHandle _
) As RebarConstraint
Visual C++
public:
RebarConstraint^ GetCurrentConstraintOnHandle(
	RebarConstrainedHandle^ handle
)

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException handle is no longer valid.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL
Autodesk.Revit.Exceptions InvalidOperationException The RebarConstraintsManager does not manage a valid Rebar element.

See Also