Specify a dimension perpendicular to two fixed-direction segments, measured by a read-only parameter.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- paramId
- Type: Autodesk.Revit.DB ElementId
Id of a parameter to report the length of the dimension. The parameter will be read-only on Rebar instances.
- constraintDirCoordX
- Type: System Double
The x-coordinate of a 2D vector specifying the constraint direction.
- constraintDirCoordY
- Type: System Double
The y-coordinate of a 2D vector specifying the constraint direction.
- iSegment0
- Type: System Int32
Index of the first segment (0 to NumberOfSegments - 1).
- iSegment1
- Type: System Int32
Index of the second segment (0 to NumberOfSegments - 1).
Remarks
RebarShapeDefinitionBySegments supports driving (read-write) dimensions only when they are associated with a single segment. Non-driving dimensions can involve multiple segments.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | paramId is not the id of a shared parameter in the current document, or its unit type is not UT_Reinforcement_Length or UT_Angle. -or- The length of the vector (constraintDirCoordX, constraintDirCoordY) is too close to zero. -or- iSegment0 is not between 0 and NumberOfSegments. -or- iSegment1 is not between 0 and NumberOfSegments. -or- Edge iSegment0 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY). -or- Edge iSegment1 has a variable angle; it must have a fixed angle perpendicular to (constraintDirCoordX, constraintDirCoordY). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |