Offsets a planar face of the free form element a certain distance in the normal direction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- face
- Type: Autodesk.Revit.DB Face
The face to offset.
- offset
- Type: System Double
The magnitude of the offset. A positive value offsets out of the input solid. A negative value offsets into the solid shape.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | face does not belong to the solid. -or- The face to be offset should be planar and satisfy constraints of its parent element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |