Returns the state of a tangent join between this and another curve element at the given end-point.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- end
- Type: System Int32
Index of one of the curve's end. Values '0' and '1' indicate the start or end point, respectively.
- other
- Type: Autodesk.Revit.DB ElementId
ElementId of another Curve Element from the same document.
Return Value
Returns True if this curve element has a tangent joint with the other input element and the join is curently locked; returns False otherwise.Remarks
The return value indicates whether there is such tangent join and if it is currently locked. A negative value indicates that there either is no tangent join with the other element at the given end-point, or the join between those two curve element is not currently locked.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The given Id does not represent any of the two end-points of a curve element. A valid value of either '0' or '1' is expected. -or- The given ElementId (%elementId) is not of a valid Curve Element. A valid Curve Element must be in the same document and must be diferent than this curve elements self. -or- This element has no tangent join with the input element at the given end-point. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |