Create Method (Document, String, ICollection(ElementId), IList(FilterRule))


Creates a new ParameterFilterElement in the given document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you instead use a Create method that takes an ElementFilter as input.")]
public static ParameterFilterElement Create(
	Document aDocument,
	string name,
	ICollection<ElementId> categories,
	IList<FilterRule> rules
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you instead use a Create method that takes an ElementFilter as input.")> _
Public Shared Function Create ( _
	aDocument As Document, _
	name As String, _
	categories As ICollection(Of ElementId), _
	rules As IList(Of FilterRule) _
) As ParameterFilterElement
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you instead use a Create method that takes an ElementFilter as input.")]
public:
static ParameterFilterElement^ Create(
	Document^ aDocument, 
	String^ name, 
	ICollection<ElementId^>^ categories, 
	IList<FilterRule^>^ rules
)

Parameters

aDocument
Type: Autodesk.Revit.DB Document
The document in which to create the ParameterFilterElement.
name
Type: System String
The user-visible name for the new ParameterFilterElement.
categories
Type: System.Collections.Generic ICollection ElementId
The categories for the new ParameterFilterElement.
rules
Type: System.Collections.Generic IList FilterRule
The rules for the new ParameterFilterElement.

Return Value

A pointer to the new ParameterFilterElement.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentException name is an empty string or contains only whitespace. -or- name cannot include prohibited characters. -or- The given value for name is already in use as a filter element name. -or- One of the given rules refers to a parameter that does not apply to this filter's categories.
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also