GetFrameworkElement Method


Wrapper function that returns the FrameworkElement for this provider.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2018

Syntax

C#
public FrameworkElement GetFrameworkElement()
Visual Basic
Public Function GetFrameworkElement As FrameworkElement
Visual C++
public:
FrameworkElement^ GetFrameworkElement()

Return Value

FrameworkElement to use as the pane's user interface.

Remarks

If an IFrameworkElementCreator is provided, that will be called to generate the element, otherwise, the FrameworkElement associated with the provider is returned.

See Also