Implement this method to check whether the given ExternalResourceReference is formatted correctly for this server.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- extRef
- Type: Autodesk.Revit.DB ExternalResourceReference
The ExternalResourceReference to check.
Return Value
True if the ExternalResourceReference represents a well-formed resource. False otherwise.Remarks
Different servers will have different requirements.
A server which loads references from a website might require that the reference map contain a key called "URL" and a value that is a valid URL.
A server which loads references from a network drive might require a key called "Drive" with a value that represents a drive name, plus a key called "Path" with a value that corresponds to a path relative to the root of the drive.
This function should not check that the resource exists on the server. It should only check that the resource is formatted correctly.