SetProjectionFillColor Method


Sets the color of the surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This function is deprecated in Revit 2019 and will be removed in the next version of Revit The new function is 'SetSurfaceForegroundPatternColor'")]
public OverrideGraphicSettings SetProjectionFillColor(
	Color color
)
Visual Basic
<ObsoleteAttribute("This function is deprecated in Revit 2019 and will be removed in the next version of Revit The new function is 'SetSurfaceForegroundPatternColor'")> _
Public Function SetProjectionFillColor ( _
	color As Color _
) As OverrideGraphicSettings
Visual C++
[ObsoleteAttribute(L"This function is deprecated in Revit 2019 and will be removed in the next version of Revit The new function is 'SetSurfaceForegroundPatternColor'")]
public:
OverrideGraphicSettings^ SetProjectionFillColor(
	Color^ color
)

Parameters

color
Type: Autodesk.Revit.DB Color
Value of the surface foreground pattern color for the override. InvalidColorValue means no override is set.

Return Value

Reference to the changed object.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also