Allow to enable or disable Temporary View Properties mode.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- viewTemplateId
- Type: Autodesk.Revit.DB ElementId
ID of DBView that will be used to override current view settings. Provide ElementId.InvalidElementId constant to disable Temporary View Properties mode.
Return Value
Returns true when DBView provided by viewTemplateId was applied and Temporary View Properties was successfully started.Remarks
Settings from view provided by viewTemplateId will be applied temporarily to current view.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | View cannot use Temporary View Properties mode in current state. |