Creates a Hermite spline with default tangency at its endpoints.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2014
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- controlPoints
- Type: System.Collections.Generic IList XYZ
The control points of the Hermite spline.
- periodic
- Type: System Boolean
True if the Hermite spline is to be periodic, false otherwise.
Return Value
The new HermiteSpline object.Remarks
The tangents at the ends of the spline are computed from the control points.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The control points array is invalid, because it doesn't contain the minimum number of points (2). |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentsInconsistentException | Curve length is too small for Revit's tolerance (as identified by Application.ShortCurveTolerance). |
Autodesk.Revit.Exceptions InvalidOperationException | Unable to construct valid HermiteSpline from given inputs. |