Sets material id to a face.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2016
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- faceId
- Type: Autodesk.Revit.DB BRepBuilderGeometryId
Id of the face to which material id will be added. faceId was returned by a call to AddFace().
- materialId
- Type: Autodesk.Revit.DB ElementId
The material id associated with the face, or invalidElementId if none. It is not verified that materialId corresponds to a valid Material element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The supplied face id doesn't correspond to a face stored in this BRepBuilder object. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This BRepBuilder object isn't accepting new data, either because it has already been used to build geometry, or because of an error. Consult the State property of the BRepBuilder object for more details. |