SurfacePatternId Property


The id of the FillPatternElement used as the foreground pattern of faces with this material in normal views.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2019 and will be removed in the next version of Revit The new property is 'SurfaceForegroundPatternId'")]
public ElementId SurfacePatternId { get; set; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2019 and will be removed in the next version of Revit The new property is 'SurfaceForegroundPatternId'")> _
Public Property SurfacePatternId As ElementId
	Get
	Set
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2019 and will be removed in the next version of Revit The new property is 'SurfaceForegroundPatternId'")]
public:
property ElementId^ SurfacePatternId {
	ElementId^ get ();
	void set (ElementId^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also