The ground plane should be an Element of type Level. This method checks to confirm that an ElementId is for a Level element.
Namespace: Autodesk.Revit.DB.Analysis
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- ccda
- Type: Autodesk.Revit.DB Document
The Document.
- groundPlaneId
- Type: Autodesk.Revit.DB ElementId
The element id to be checked to confirm that it is suitable to be a ground plane (i.e., that it is a level) or that it is invalidElementId. Setting ground plane with invalidElementId will lead to the ground plane being "reset".
Return Value
True if the input element is a level or invalidElementId, false otherwise.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |