Orientation of the Assembly Detail View.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Members
Member name | Description |
---|---|
HorizontalDetail | The Detail View will be oriented horizontally, looking down. |
DetailSectionA | The Detail View will be oriented vertically, looking north. |
DetailSectionB | The Detail View will be oriented vertically, looking west. |
ElevationTop | The Detail View will be oriented horizontally, with its cut plane along the top face of the assembly's bounding box, looking down into the bounding box. |
ElevationBottom | The Detail View will be oriented horizontally, with its cut plane along the bottom face of the assembly's bounding box, looking up into the bounding box. |
ElevationLeft | The Detail View will be oriented vertically, with its cut plane along the left face of the assembly's bounding box, looking into the bounding box. |
ElevationRight | The Detail View will be oriented vertically, with its cut plane along the right face of the assembly's bounding box, looking into the bounding box. |
ElevationFront | The Detail View will be oriented vertically, with its cut plane along the front face of the assembly's bounding box, looking into the bounding box. |
ElevationBack | The Detail View will be oriented vertically, with its cut plane along the back face of the assembly's bounding box, looking into the bounding box. |
Remarks
The orientation can be specified during creation but not modified for existing views.