Writes the given TransmissionData into the Revit file at the given location.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- path
- Type: Autodesk.Revit.DB ModelPath
A ModelPath indicating the file Revit should write the TransmissionData of. This ModelPath must be a file path and an absolute path.
- data
- Type: Autodesk.Revit.DB TransmissionData
The TransmissionData to be written into the document. Note that Revit will not check that the ElementIds in the TransmissionData correspond to real Elements.
Remarks
This function will overwrite the existing TransmissionData in the file.
This function will not support models on Revit Server. References may be to Revit Server, but the host model must be local.
This function must be called on a closed document.
This function cannot be used to convert a reference from a local file to an external server.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions FileArgumentNotFoundException | There is not a valid Revit file at path's location |
Autodesk.Revit.Exceptions InvalidOperationException | Operation is not valid for Revit Server models. -or- This function cannot be called on an opened document. |