Creates a slab within the project with the given horizontal profile using the default floor style.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- profile
- Type: Autodesk.Revit.DB CurveArray
An array of planar lines and arcs that represent the horizontal profile of the slab.
- level
- Type: Autodesk.Revit.DB Level
The level on which the slab is to be placed.
- slopedArrow
- Type: Autodesk.Revit.DB Line
A line use to control the sloped angle of the slab. It should be in the same face with profile.
- slope
- Type: System Double
The slope.
- isStructural
- Type: System Boolean
If set, specifies that the floor is structural in nature.
Return Value
If successful a new floor object within the project, otherwise a null reference ( Nothing in Visual Basic) .Remarks
The curves of the profile must be contiguous and the Face formed by profile should be suitable to create slab.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the level does not exist in the given document. |