Updates the geometry of the FreeForm element to the given shape preserving References to the existing geometry where possible (see remarks for rules).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- newGeometry
- Type: Autodesk.Revit.DB Solid
The new geometry to set in the FreeForm element.
Remarks
Rules for preserving References:
- First preserve faces as Reference when exclusively coincident with existing faces.
- Then preserve faces as Reference if exclusively parallel to existing faces.
- Then preserve faces as Reference if exclusive at small angle to the existing faces.
- Any other faces are will not be preserved as a Reference.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |