GetAllTypes Method


Gets all the analytical connection types.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2018

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit.")]
public static ISet<ElementId> GetAllTypes(
	Document doc
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit.")> _
Public Shared Function GetAllTypes ( _
	doc As Document _
) As ISet(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit.")]
public:
static ISet<ElementId^>^ GetAllTypes(
	Document^ doc
)

Parameters

doc
Type: Autodesk.Revit.DB Document
The document where the analytical connection types come from.

Return Value

All the types in this document, empty if none.

Remarks

We suggest you use the generic mechanism [!:Autodesk::Revit::DB::FilteredElementCollector] .

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also