Sets the bar in this rebar set to be hidden or unhidden in the given view.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view.
- barIndex
- Type: System Int32
The index of the bar from this set.
- hide
- Type: System Boolean
True to hide this bar in the view, false to unhide the bar.
Remarks
Individual bars of a rebar set can be hidden in a view only if the presentation mode is RebarPresentationMode.Select. If that is not the presentation mode assigned for this set in the view, this method will also change it.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | This rebar cannot have a presentation mode applied for view, as the view is not valid for rebar presentation, or the orientation of the view matches the normal direction of the rebar element. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | barIndex is not in the range [ 0, NumberOfBarPositions-1 ]. |
Autodesk.Revit.Exceptions DisabledDisciplineException | None of the following disciplines is enabled: Structural. |
Autodesk.Revit.Exceptions InapplicableDataException | This rebar element represents a single bar (the layout rule is Single). |