CanAddBarGeometry Method


If the layout rule is Singe or FixedNumber or NumberWithSpacing this function will return true if getNumberOfBarGeometry() is less getBarsNumber(), false otherwise.

If the layout rule is MaximumSpacing or MinimumClearSpacing this function will return always true.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public bool CanAddBarGeometry()
Visual Basic
Public Function CanAddBarGeometry As Boolean
Visual C++
public:
bool CanAddBarGeometry()

Return Value

Returns true if we can add more bar geometry for the current layout, false otherwise.

See Also