Gets a list of valid parameters for the specified category that can be used in the table view.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- cda
- Type: Autodesk.Revit.DB Document
The document.
- categoryId
- Type: Autodesk.Revit.DB ElementId
The specified element category id.
Return Value
The IDs of all valid parameters.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |