IsProjectLocationNameUnique Method


Verifies that there is no existing ProjectLocation with the given name in the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2018

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'ProjectLocation::IsProjectLocationNameUnique(Autodesk::Revit::DB::Document ^document, System::String ^name, Autodesk::Revit::DB::ElementId ^siteLocationId)' method instead.")]
public static bool IsProjectLocationNameUnique(
	Document document,
	string name
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'ProjectLocation::IsProjectLocationNameUnique(Autodesk::Revit::DB::Document ^document, System::String ^name, Autodesk::Revit::DB::ElementId ^siteLocationId)' method instead.")> _
Public Shared Function IsProjectLocationNameUnique ( _
	document As Document, _
	name As String _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest you use the 'ProjectLocation::IsProjectLocationNameUnique(Autodesk::Revit::DB::Document ^document, System::String ^name, Autodesk::Revit::DB::ElementId ^siteLocationId)' method instead.")]
public:
static bool IsProjectLocationNameUnique(
	Document^ document, 
	String^ name
)

Parameters

document
Type: Autodesk.Revit.DB Document
The document to check.
name
Type: System String
The name to check.

Return Value

True if the name is unused (among ProjectLocations). False otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also