ComputeDrivingCurves Method


Compute the driving curves.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Since: 2016

Syntax

C#
public IList<Curve> ComputeDrivingCurves()
Visual Basic
Public Function ComputeDrivingCurves As IList(Of Curve)
Visual C++
public:
IList<Curve^>^ ComputeDrivingCurves()

Return Value

Returns an empty array if an error is encountered.

Remarks

The driving curves are the ones that appear in rebar sketch mode. They include lines and arcs that drive the shape, but exclude fillets and hooks. They always lie in a plane-- if the bar is 3D, these curves are a subset or a projection. They are also used for shape matching.

See Also