Adjust the width of an existing simple region.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- regionId
- Type: System Int32
The id of a region.
- newWidth
- Type: System Double
The desired width of the specified region.
Return Value
True if newWidth is zero and the region was deleted.Remarks
If width is changed to zero, the effect is to delete the region.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | It is not a valid region id. -or- It is not a simple region. |
Autodesk.Revit.Exceptions InvalidOperationException | This operation is valid only for vertically compound structures. |