FrameworkElementCreator Property


A creator that will be called for the pane if the FrameworkElement is not set.

Namespace: Autodesk.Revit.UI
Assembly: RevitAPIUI (in RevitAPIUI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public IFrameworkElementCreator FrameworkElementCreator { get; set; }
Visual Basic
Public Property FrameworkElementCreator As IFrameworkElementCreator
	Get
	Set
Visual C++
public:
property IFrameworkElementCreator^ FrameworkElementCreator {
	IFrameworkElementCreator^ get ();
	void set (IFrameworkElementCreator^ value);
}

Remarks

This is more dynamic in nature and allows for embedding things like WebBrowser controls that cannot be cached for reuse in each pane invocation but rather needs creating each time.

See Also