Sets the additional reference element for the failure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- additionalElement
- Type: Autodesk.Revit.DB ElementId
The additional element.
Return Value
The FailureMessage.Remarks
Additional elements are used to highlight additional information to the user. They are not considered as causing the failure, but are related to it. User cannot delete them in extended error dialog.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | This FailureMessage is already posted to a document |