Generate a new spot elevation object within the project.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- view
- Type: Autodesk.Revit.DB View
The view in which the spot elevation is to be visible.
- reference
- Type: Autodesk.Revit.DB Reference
The reference to which the spot elevation is to be bound.
- origin
- Type: Autodesk.Revit.DB XYZ
The point which the spot elevation evaluate.
- bend
- Type: Autodesk.Revit.DB XYZ
The bend point for the spot elevation.
- end
- Type: Autodesk.Revit.DB XYZ
The end point for the spot elevation.
- refPt
- Type: Autodesk.Revit.DB XYZ
The actual point on the reference which the spot elevation evaluate.
- hasLeader
- Type: System Boolean
Indicate if it has leader or not.
Return Value
If successful a new spot dimension object, otherwise a null reference ( Nothing in Visual Basic) .Remarks
If the origin point is not on the reference, it'll be projected to the reference automatically. And the refPt is the projected point. If the reference is not valid or the point cannot be projected to reference correctly, an exception will be thrown
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | Thrown if the view does not exist in the given document. |