AllRuleParametersApplicable Method (IList(FilterRule))


Checks that the parameters of the given rules are valid for this filter's categories.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. The functions that need this validator have themselves been deprecated in Revit 2019.")]
public bool AllRuleParametersApplicable(
	IList<FilterRule> rules
)
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. The functions that need this validator have themselves been deprecated in Revit 2019.")> _
Public Function AllRuleParametersApplicable ( _
	rules As IList(Of FilterRule) _
) As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. The functions that need this validator have themselves been deprecated in Revit 2019.")]
public:
bool AllRuleParametersApplicable(
	IList<FilterRule^>^ rules
)

Parameters

rules
Type: System.Collections.Generic IList FilterRule
The rules to check.

Return Value

True if all the parameters of the given rules are valid for this filter, otherwise false.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also