UsesConjunctionOfFilterRules Method


Returns 'true' if and only if this ParameterFilterElement uses a pure conjunction ("ANDing together") of FilterRules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. It is used as a validator for GetRules, which is also deprecated in Revit 2019.")]
public bool UsesConjunctionOfFilterRules()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. It is used as a validator for GetRules, which is also deprecated in Revit 2019.")> _
Public Function UsesConjunctionOfFilterRules As Boolean
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. It is used as a validator for GetRules, which is also deprecated in Revit 2019.")]
public:
bool UsesConjunctionOfFilterRules()

Return Value

True if this filter uses a pure conjunction of FilterRules, false if not.

See Also