ImageType Class


Represents a type containing an image. Instances of this type can be displayed in 2D views, sheets, and schedules.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2015

Syntax

C#
public class ImageType : ElementType
Visual Basic
Public Class ImageType _
	Inherits ElementType
Visual C++
public ref class ImageType : public ElementType

Remarks

ImageType elements are created when importing images for placement in a 2D view via Document.Import(string, ImageImportOptions, View, out Element).

ImageType elements can also be created without corresponding instances (for example, to add them to cells in schedules).

Inheritance Hierarchy

See Also