Returns the first element to pass the filter(s).
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Return Value
The first element.Remarks
This will reset the collector to the beginning and find the first element that passes the applied filter(s). If you have an active iterator to this same collector it will be stopped by this call.
Examples

public FamilyInstance GetAColumn(Autodesk.Revit.DB.Document document)
{
// Create a filter to find all columns
StructuralInstanceUsageFilter columnFilter =
new StructuralInstanceUsageFilter(StructuralInstanceUsage.Column);
// Apply the filter to the elements in the active document
FilteredElementCollector collector = new FilteredElementCollector(document);
collector.WherePasses(columnFilter);
// Get the first column from the filtered results
// Element will be a FamilyInstance
FamilyInstance column = collector.FirstElement() as FamilyInstance;
return column;
}

Public Function GetAColumn(document As Autodesk.Revit.DB.Document) As FamilyInstance
' Create a filter to find all columns
Dim columnFilter As New StructuralInstanceUsageFilter(StructuralInstanceUsage.Column)
' Apply the filter to the elements in the active document
Dim collector As New FilteredElementCollector(document)
collector.WherePasses(columnFilter)
' Get the first column from the filtered results
' Element will be a FamilyInstance
Dim column As FamilyInstance = TryCast(collector.FirstElement(), FamilyInstance)
Return column
End Function
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions InvalidOperationException | The collector does not have a filter applied. Extraction or iteration of elements is not permitted without a filter. |