Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2017
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Field Value
The display types are: Standard - standard display type; will not display anything for multiple elements with different values. Totals - In a non-itemized schedule, totals are displayed in regular rows when multiple elements appear on the same row. Min - In a non-itemized schedule, minimum value is displayed in regular rows when multiple elements appear on the same row. Max - In a non-itemized schedule, maximum value is displayed in regular rows when multiple elements appear on the same row. MinMax - In a non-itemized schedule, Minimum/Maximum values are displayed in regular rows when multiple elements appear on the same row.
Remarks
This replaces the hasTotals property from 2017. The hasTotals = true is same as DisplayType::Totals; hasTotals = false is the same as DisplayType::Standard. This also adds the ability to see Min/Max for grouped elements.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |
Autodesk.Revit.Exceptions InvalidOperationException | When setting this property: This ScheduleField cannot display minimum and maximum values. -or- When setting this property: This ScheduleField cannot be totaled. |