FamilyLoadingIntoDocument Event


Subscribe to the FamilyLoadingInto event to be notified when Revit is just about to load a family into a document.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2015

Syntax

C#
public event EventHandler<FamilyLoadingIntoDocumentEventArgs> FamilyLoadingIntoDocument
Visual Basic
Public Event FamilyLoadingIntoDocument As EventHandler(Of FamilyLoadingIntoDocumentEventArgs)
Visual C++
public:
 event EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ FamilyLoadingIntoDocument {
	void add (EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ value);
	void remove (EventHandler<FamilyLoadingIntoDocumentEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to load a family into a document.

Handlers of this event are permitted to make modifications to any document (including the active document), except for documents that are currently in read-only mode.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another FamilyLoadedIntoDocument event will be raised immediately after family loading is finished.

See Also