Converts a pair of cloud project and model GUIDs to a valid cloud path.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2019
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- projectId
- Type: System Guid
The GUID of the cloud project which contains the model.
- modelId
- Type: System Guid
The GUID of the Revit cloud model.
Return Value
The cloud model path.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions CentralModelException | The cloud model is missing. |
Autodesk.Revit.Exceptions RevitServerCommunicationException | The central server could not be reached. |
Autodesk.Revit.Exceptions RevitServerUnauthenticatedUserException | You must sign in to Autodesk 360 in order to complete action. |
Autodesk.Revit.Exceptions RevitServerUnauthorizedException | You are unauthorized to access this resource. |