Executes selected rules on a given document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- document
- Type: Autodesk.Revit.DB Document
Document on which the rules will be executed.
- rules
- Type: System.Collections.Generic IList PerformanceAdviserRuleId
Ids of rules to be executed.
Return Value
Failure messages explaining performance problems detected in the document.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |