GetRuleParameters Method


Retrieves a list of the parameters associated with each rule in the filter. The order of the resulting array corresponds to the order in which the associated filter rules are applied.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2011

Syntax

C#
[ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest that you use GetElementFilterParameters instead.")]
public IList<ElementId> GetRuleParameters()
Visual Basic
<ObsoleteAttribute("This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest that you use GetElementFilterParameters instead.")> _
Public Function GetRuleParameters As IList(Of ElementId)
Visual C++
[ObsoleteAttribute(L"This method is deprecated in Revit 2019 and will be removed in the next version of Revit. We suggest that you use GetElementFilterParameters instead.")]
public:
IList<ElementId^>^ GetRuleParameters()

Return Value

An array of parameter identifiers.

See Also