Adds a new flexible pipe into the document, using two connector, and flexible pipe type.
Namespace: Autodesk.Revit.Creation
Assembly: RevitAPI (in RevitAPI.dll) Version: 16.0.0.0 (16.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- connector1
- Type: Autodesk.Revit.DB Connector
The first connector to be connected to the pipe.
- connector2
- Type: Autodesk.Revit.DB Connector
The second connector to be connected to the pipe.
- pipeType
- Type: Autodesk.Revit.DB.Plumbing FlexPipeType
The type of the flexible pipe.
Return Value
If creation was successful then a new flexible pipe is returned, otherwise an exception with failure information will be thrown.Remarks
If the connectors are fitting or equipment connectors of the correct domain, and if the connectors' direction match the direction of the flexible pipe to be created, the connectors will be automatically connected. A transition fitting will be added at the connector(s) if necessary. If the connector's type, domain, does not match the one of the input connectors, no connection will be established.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | Thrown when the input argument connector1 or connector2 is a null reference ( Nothing in Visual Basic) . |
Autodesk.Revit.Exceptions InvalidOperationException | Thrown when the flexible pipe cannot be created or regenerate fails. |
Autodesk.Revit.Exceptions ArgumentException | Thrown if the flexible pipe type does not exist in the given document. |