Normal Property


A unit-length vector normal to the plane of the rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 18.0.0.0 (18.0.0.420)
Since: 2018

Syntax

C#
public XYZ Normal { get; }
Visual Basic
Public ReadOnly Property Normal As XYZ
	Get
Visual C++
public:
property XYZ^ Normal {
	XYZ^ get ();
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions InvalidOperationException This RebarShapeDrivenAccessor doesn't contain a valid rebar reference.

See Also