ElementTypeDuplicating Event


Subscribe to the ElementTypeDuplicating event to be notified when Revit is just about to duplicate an element type.

Namespace: Autodesk.Revit.ApplicationServices
Assembly: RevitAPI (in RevitAPI.dll) Version: 17.0.0.0 (17.0.1090.0)
Since: 2015

Syntax

C#
public event EventHandler<ElementTypeDuplicatingEventArgs> ElementTypeDuplicating
Visual Basic
Public Event ElementTypeDuplicating As EventHandler(Of ElementTypeDuplicatingEventArgs)
Visual C++
public:
 event EventHandler<ElementTypeDuplicatingEventArgs^>^ ElementTypeDuplicating {
	void add (EventHandler<ElementTypeDuplicatingEventArgs^>^ value);
	void remove (EventHandler<ElementTypeDuplicatingEventArgs^>^ value);
}

Remarks

This event is raised when Revit is just about to duplicate an element type.

Event is cancellable. To cancel it, call the 'Cancel()' method in event's argument to True. Your application is responsible for providing feedback to the user about the reason for the cancellation.

The following API functions are not available for the current document during this event:

Exception InvalidOperationException will be thrown if any of the above methods is called during this event.

Another ElementTypeDuplicated event will be raised immediately after duplicating an element type is finished.

See Also