Constructs a filter to match elements which intersect the given element, with the option to match all elements not intersecting the given element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- element
- Type: Autodesk.Revit.DB Element
The element to check for intersection.
- inverted
- Type: System Boolean
True if the filter should match all elements which do not intersect the given element.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The category of the element is not supported for element intersection filters. -or- The element is not supported for element intersection filters. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |