SetCutFillPatternId Method


Sets the ElementId of the cut face foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)
Since: 2014

Syntax

C#
[ObsoleteAttribute("This function is deprecated in Revit 2019 and will be removed in the next version of Revit The new function is 'SetCutForegroundPatternId'")]
public OverrideGraphicSettings SetCutFillPatternId(
	ElementId fillPatternId
)
Visual Basic
<ObsoleteAttribute("This function is deprecated in Revit 2019 and will be removed in the next version of Revit The new function is 'SetCutForegroundPatternId'")> _
Public Function SetCutFillPatternId ( _
	fillPatternId As ElementId _
) As OverrideGraphicSettings
Visual C++
[ObsoleteAttribute(L"This function is deprecated in Revit 2019 and will be removed in the next version of Revit The new function is 'SetCutForegroundPatternId'")]
public:
OverrideGraphicSettings^ SetCutFillPatternId(
	ElementId^ fillPatternId
)

Parameters

fillPatternId
Type: Autodesk.Revit.DB ElementId
ElementId of the cut face foreground fill pattern for the override. InvalidElementId means no override is set. The pattern must be a drafting pattern.

Return Value

Reference to the changed object.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also