Gets associated PartMaker for an element.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- hostDocument
- Type: Autodesk.Revit.DB Document
The document
- elementId
- Type: Autodesk.Revit.DB ElementId
The id for the element to be checked for associated Parts
Return Value
The PartMaker element that is making Parts for this element. a null reference ( Nothing in Visual Basic) if there is no associated PartMaker.Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |