SurfacePatternColor Property


The color of the material surface foreground pattern.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 19.0.0.0 (19.0.0.405)

Syntax

C#
[ObsoleteAttribute("This property is deprecated in Revit 2019 and will be removed in the next version of Revit The new property is 'SurfaceForegroundPatternColor'")]
public Color SurfacePatternColor { get; set; }
Visual Basic
<ObsoleteAttribute("This property is deprecated in Revit 2019 and will be removed in the next version of Revit The new property is 'SurfaceForegroundPatternColor'")> _
Public Property SurfacePatternColor As Color
	Get
	Set
Visual C++
[ObsoleteAttribute(L"This property is deprecated in Revit 2019 and will be removed in the next version of Revit The new property is 'SurfaceForegroundPatternColor'")]
public:
property Color^ SurfacePatternColor {
	Color^ get ();
	void set (Color^ value);
}

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException When setting this property: A non-optional argument was NULL

See Also