Creates a field containing an array of values in the Schema, with given name and type of contained values.
Namespace: Autodesk.Revit.DB.ExtensibleStorage
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2012
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- fieldName
- Type: System String
The name of the new field.
- fieldType
- Type: System Type
The type of the contents in the new field.
Return Value
The FieldBuilder object may be used to add more details to the field. Make sure to set the unit type if the field contains floating-point values.Remarks
The supported types for the contents are the same as for simple fields. See AddSimpleField(String, Type) for details.
Note that a schema may contain a maximum of 256 fields.
Exceptions
Exception | Condition |
---|---|
Autodesk.Revit.Exceptions ArgumentException | The parameter fieldName is not acceptable for naming Extensible Storage objects. -or- The field type is not supported. |
Autodesk.Revit.Exceptions ArgumentNullException | A non-optional argument was NULL |
Autodesk.Revit.Exceptions InvalidOperationException | The SchemaBuilder has already finished building the Schema. |