Return a surface normal on either the top or bottom face of a floor slab at a point corresponding to the vertical projection of an arbitrary point in project space.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Syntax
C# |
---|
|
Visual Basic |
---|
|
Visual C++ |
---|
|
Parameters
- modelLocation
- Type: Autodesk.Revit.DB XYZ
A point in project coordinates whose vertical projection will determine the location at which the normal will be taken.
- floorFace
- Type: Autodesk.Revit.DB FloorFace
A flag determining whether the top or bottom face of the floor should be used.
Return Value
Normal vector on the slab at the projection point.Remarks
If the floor is shape edited, the floor location at which we attempt to take the normal must be within the boundaries of a face on the slab. Otherwise the method will return a null reference ( Nothing in Visual Basic) .