IsValidDatumPlaneForProjection Method


Indicates whether Datum Plane is valid Analytical Projection of Sketch Component.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 2015.0.0.0 (2015.0.0.0)
Since: 2011

Syntax

C#
public bool IsValidDatumPlaneForProjection(
	ElementId datumPlaneId
)
Visual Basic
Public Function IsValidDatumPlaneForProjection ( _
	datumPlaneId As ElementId _
) As Boolean
Visual C++
public:
bool IsValidDatumPlaneForProjection(
	ElementId^ datumPlaneId
)

Parameters

datumPlaneId
Type: Autodesk.Revit.DB ElementId
ElementId identifying Datum Plane.

Return Value

True if Datum Plane is valid; false otherwise.

Exceptions

Exception Condition
Autodesk.Revit.Exceptions ArgumentNullException A non-optional argument was NULL

See Also